1 Reply Latest reply on Oct 31, 2018 9:49 AM by yairi

    Installing OFED on FC27 throwing compiler errors

    petermcc

      Hi,

      I am currently trying to install OFED drivers for FC27. I had a FC 26 install (kernel 4.16.11-100.fc26.x86_64), but upgraded to FC 27 based on documentation. As part of the upgrade I upgraded the kernel to the following 4.18.15-100.fc27.x86_64. I then went to install, and had to build kernel support

       

      ./MLNX_OFED_LINUX-4.4-1.0.0.0-fc27-x86_64/mlnxofedinstall --add-kernel-support

      Unfortunately the version is the kernel isn't compatible with this version of OFED, as I was getting the following 2 compile errors

       

      OFED EXPECTS THIS BE RETURNING AN INT - /lib/modules/4.18.15-100.fc27.x86_64/build/include/linux/mm.h

      void zap_vma_ptes(struct vm_area_struct *vma, unsigned long address, unsigned long size);

       

      OFED DOES NOT EXPECT "const struct sk_buff *skb" parameter in API in /lib/modules/4.18.15-100.fc27.x86_64/build/include/net/ip6_route.h

      struct rt6_info *rt6_lookup(struct net *net, const struct in6_addr *daddr, const struct in6_addr *saddr, int oif, const struct sk_buff *skb, int flags);

       

      After examination, it would seem that the older kernel version (4.16.11-100.fc26.x86_64), has the correct form of the above APIs and the drivers can be build against this. So I went back to a FC26 install, however the install fails immediately now as it expects a FC27 install.

       

      At this point I am unclear how I should proceed. Should I upgrade from 26-27 and not update the kernel, I believe this will work. I want to do the recommended solution. Any guidance on this matter would be greatly appreciated.

       

      Regards

      Peter McCarthy