1 Reply Latest reply on Sep 6, 2018 9:30 AM by yairi

    mlx5 IPoIB not working in connected mode

    mlxfddi

      Hello,

      I am trying to have my hosts connected on my infiniband network with mlx5 cards in connected mode but IPoIB is not working.

      CONNECTED MODE is mandatory in my environment.

       

      I disabled IPoIB enhanced mode

       

      options ib_ipoib ipoib_enhanced=0

       

      in this way I configured ib0 as a connected mode IPoIB

       

      ib0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 65520 qdisc pfifo_fast state UP group default qlen 256

          link/infiniband 80:00:00:86:fe:80:00:00:00:00:00:00:50:6b:4b:03:00:42:e7:b4 brd 00:ff:ff:ff:ff:12:40:1b:ff:ff:00:00:00:00:00:00:ff:ff:ff:ff

          inet 172.21.52.144/22 brd 172.21.55.255 scope global ib0

       

       

      while ibping works, ping itself does not work and I Am not able to use the interfaces.

       

      server 1: 172.21.52.144

      server 2: 172.21.52.145

       

      they cannot ping each other while they can ibping each other.

       

      my systems are RHEL 7.5  3.10.0-862.11.6.el7.x86_64

       

      here is the info of my mlx5 card.

      how can I enable connected mode to work on these interfaces?

       

      CA 'mlx5_0'

          CA type: MT4115

          Number of ports: 1

          Firmware version: 12.23.1020

          Hardware version: 0

          Node GUID: 0x506b4b030042e7b4

          System image GUID: 0x506b4b030042e7b4

          Port 1:

              State: Active

              Physical state: LinkUp

              Rate: 100

              Base lid: 3

              LMC: 0

              SM lid: 1

              Capability mask: 0x2659e848

              Port GUID: 0x506b4b030042e7b4

              Link layer: InfiniBand

       

      thank you