1 Reply Latest reply on Sep 25, 2018 6:55 PM by yairi

    How to enable the MT4103(connectx-3 pro) physical port

    lane

      It is found that when configuring the adapter as RoCEv2 by “options mlx4_core roce_mode=0000:81:00.0-1,0000:84:00.0-1”, after OS rebooting, one MT4103 can not work well. But there is nothing wrong for another one with the same firmware.

       

      The port state always shows “Disabled" as below:

      # ibstat mlx4_1

      CA ‘mlx4_1’

        CA type: MT4103

        Number of ports: 1

        Firmware version: 2.42.5000

        Hardware version: 0

        Node GUID: 0xe41d2d030029ecb0

        System image GUID: 0xe41d2d030029ecb0

        Port 1:

        State: Down

        Physical state: Disabled

        Rate: 10

        Base lid: 0

        LMC: 0

        SM lid: 0

        Capability mask: 0x04010000

        Port GUID: 0xe61d2dfffe29ecb0

        Link layer: Ethernet

       

      And related ethnet interface’s link can not be detectable, but actually the cable is connected.

      # ethtool ens259

      Settings for ens259:

        Supported ports: [ FIBRE ]

        Supported link modes:   1000baseKX/Full

        Supported pause frame use: Symmetric Receive-only

        Supports auto-negotiation: No

        Advertised link modes:  1000baseKX/Full

        Advertised pause frame use: Symmetric

        Advertised auto-negotiation: No

        Speed: Unknown!

        Duplex: Unknown! (255)

        Port: FIBRE

        PHYAD: 0

        Transceiver: internal

        Auto-negotiation: off

        Supports Wake-on: d

        Wake-on: d

        Current message level: 0x00000014 (20)

               link ifdown

        Link detected: no

       

      I have tried OFED driver of MLNX_OFED_LINUX-4.4-1.0.0.0-rhel7.4-x86_64 and MLNX_OFED_LINUX-4.4-2.0.7.0-rhel7.4-x86_64. Neither can work.

       

      The switch is Dell 4048-on.

       

      So, what is the problem with one MT4103? How can I enable the physical port?

        • Re: How to enable the MT4103(connectx-3 pro) physical port
          yairi
          This message was posted by Yair Ifergan on behalf of Martijn van Breugel

          Hello Liang,

          Thank you for posting your question on the Mellanox Community.

          Based on the information provided, we see that you correctly configure RoCEv2 on the adapter. Based on the 'ibstat' output, there is no physical link to the switch.

          Please check the cable used, make sure it is a validated and supported cable based on the latest Release Notes of the ConnectX-3 Pro firmware in use.

          Also check, if the port on the switch is disabled. If needed move the link to another switch port. Also on the adapter, please perform a back-to-back between the two adapters to see if the link comes up.

          If after this the issue is not resolved, please open a Mellanox Support case by sending an email to support@mellanox.com.

          Thanks and regards,
          ~Mellanox Technical Support