0 Replies Latest reply on Aug 7, 2018 1:11 PM by alwezhpy

    Need help updating firmware/speed for MNPA19-XTR adapters

    alwezhpy

      I need faster peer to peer access between a server and desktop computer.  I installed an MNPA19-XTR 10Gb adapter in each machine with a Peer to Peer configuration w/SFP+ copper cable.  The issue/problem is they are not performing as they should.  When a large transfer is started, the speed starts at just under 700Mb/s (which is expected or even better than expected with SATA HD's in use).  But after 5-6 seconds, the speed starts dropping to 100-150Mb/s.  Intermittently, the speed will jump up to 400-500Mb/s for a second or two, then drop down again. Both systems have an SSD, Single SATA and a SATA array of disks.  So, I have tried the tests from SSD to SSD, SATA to SATA, etc, and the results are pretty much the same.  All offloading is enabled, Jumbo Packet is at 9000, send/recv buffers are at max and I have tried tuning as many settings as I can find including specifying both 10Gb adapters in the Hosts file.  It almost seems like it is a heat issue even though there is plenty of air movement.

      I don't know if speed will improve with a firmware update, but MLXUP.exe does not recognize my adapter (not sure if I am using the correct switch(es) in the command line (windows machines).  Any help with either or both speed and firmware updating would be highly appreciated.  The cards currently have firmware rev 2.9.1000 and I have 2.9.1200 on hand to update.  I will be extremely happy if I can get a reliable 400-500Mb/s out of this setup, which is what I believe it should be at.

      System 1:

      ASUS X370-A MB, Ryzen 5 1600, 16Mb RAM, 500Gb SSD, 6-4Tb NAS SATA disk array, 1-3Tb NAS SATA disk.

      System 2:

      ASUS X370-Pro MB, Ryzen 7 1800X, 32Mb RAM, 240Gb SSD, 6-4Tb NAS SATA disk array, 1-6Tb NAS SATA disk.

      Also it looks like I have to choose a group for this discussion, so I am just choosing the closest fit.

      Thank you in advance for any help.