1 Reply Latest reply on Aug 28, 2018 10:22 AM by martijn@mellanox.com

    ConnectX-2 10GbE Ethernet "Flash not found", FW update problem

    szolnoki

      Dear Community,

       

      I have two Mellanox ConnectX-2 Ethernet card (MNPA19-XTR).

      In Linux, I see only:

      01:00.0 Memory controller: Mellanox Technologies MT25408 [ConnectX IB SDR Flash Recovery] (rev b0)

       

      I tired update the FW with different versions of MFT Tools (2.7, 3.x, 4.x) but no success. I follow and try many Google results.

      I got always: "-E- Failed to query 0000:01:00.0 device, error : No such file or directory. MFE_NO_FLASH_DETECTED"

      If I force flash chip type, I got: "Flash write failed: Flash erase of address 0x80000 failed: MFE_WRITE_TIMEOUT"

       

      ("Flash is not present" jumper = opened)

       

      I attached a text file, with relevant flashing/query outputs.

       

      Thank you for answer.

      Ps: Mellanox support not helps, because I have no "contract".

        • Re: ConnectX-2 10GbE Ethernet "Flash not found", FW update problem
          martijn@mellanox.com

          Hi Tibor,

           

          Many thanks for reaching out to the Mellanox Community.

           

          Please check if reburning your firmware when the card is booted in the Livefish mode, resolve your issue. If this does not resolve the issue, the card is dead.

           

          For booting you card into Livefish mode, please follow the instructions in the MFT (Mellanox Firmware Tools) User Manual ( http://www.mellanox.com/related-docs/MFT/MFT_user_manual_4_10_0.pdf ), Appendix C: "Booting HCA Device in Livefish Mode".

           

          For correctly burning the firmware in this mode, please use the following command:

          # flint -d <device> -i <firmware bin file> -nofs -guid <card guid> burn GUID can be found on the HCA sticker.

          Example:

          # flint -d /dev/mst/mt26428_pciconf0 -i MNPH29C-XTR.bin -nofs –guid 0002C903000B6D1C burn

           

          After successful burning the firmware, please reboot the card in Normal mode.

           

          Many thanks,

          ~Mellanox Technical Support