2 Replies Latest reply on Jun 24, 2018 11:04 PM by hosse

    igmp mlag vlan config right?

    hosse

      Hello,

       

      Setup 2xSX1012 VERSION 3.6.4112 IGMP in mlag please help me!

      I have a installation with 4xNode with 2x40Gb Ethernet on node and need IGMP snooping with querier on vlan 1.

       

      Configuration of the SX1012:

      Port 1-4 = Mpo1-Mpo4

      Port 11 = Po11

       

      IPL    VLAN     IP          Partner

      Po11   4000     1.1.1.1     1.1.1.2

       

      #Instruction mellanox:

      #Enable snooping on vlan 1

      enable

      configure terminal

      vlan 1

      ip igmp snooping

       

      #enable igmp querier

      enable

      configure terminal

      vlan 1

      ip igmp snooping querier

       

      #define mrouter port Po11 Mpo1 Mpo2 Mpo3 Mpo4

      enable

      configure terminal

      interface Po11

      switchport mode trunk

      vlan 1

      ip igmp snooping mrouter interface Po11

      # Do I have to define here all affected ports as mrouter or only Po11?

       

      #enable fast-leave

      ip igmp snooping fast-leave

       

      #create static-group

      ip igmp snooping static-group 232.43.211.234 interface Po11 192.168.1.1 192.168.1.2 192.168.1.3 192.168.1.4

      # Is this command correct?

       

      # Are there any other commands to install the installation correctly?

      # Must the querier IP address be set on vlan 1?

      # Is the configuration the same on both SX1012?

       

      Greetings

      Mario Hosse

        • Re: igmp mlag vlan config right?
          pratikpande
          • You will need to enable IGMP snooping globally.  IGMP snooping has global admin state, and per VLAN admin state. Both states need to be enabled in order to enable the IGMP snooping on a specific VLAN.

                 switch(config)# ip igmp snooping 

           

          • Enable IGMP snooping and IGMP querier on Vlan 1

                  switch(config) # vlan 1 ip igmp snooping

                  switch(config) # vlan 1 ip igmp snooping querier

           

          • IPL port channel is by default an mrouter port. So you will need to configure the MPo's as mrouter ports

                  switch(config) # vlan 1 ip igmp snooping mrouter interface mlag-port-channel 1 
                  switch(config) # vlan 1 ip igmp snooping mrouter interface mlag-port-channel 2

                  switch(config) # vlan 1 ip igmp snooping mrouter interface mlag-port-channel 3

                  switch(config) # vlan 1 ip igmp snooping mrouter interface mlag-port-channel 4

           

          • To enables fast leave processing on a specific interfaces

                 switch(config) # interface mlag-port-channel 1 ip igmp snooping fast-leave

           

          • To create static-group

                 ip igmp snooping static-group <IP address> interface <type> <number> [source<source-IP>] 

                 switch(config)# ip igmp snooping static-group 232.43.211.234 interface mlag-port-channel 1 source 192.168.1.1 192.168.1.2 192.168.1.3 192.168.1.4

           

          • Must the querier IP address be set on vlan 1?

                 It is a source for the IGMP queries. So always recommended to have in address set on vlan 1

           

          • Is the configuration the same on both SX1012?

                   Yes

           

          Please also refer the our Mellanox Onyx UM for more details about configuring IGMP snooping on Mellanox Switches.

            • Re: igmp mlag vlan config right?
              hosse

              Thank you for the answers to my questions!

              One Correct:

              Wrong command:

              ip igmp snooping static-group 232.43.211.234 interface mlag-port-channel 1 source 192.168.1.1 192.168.1.2 192.168.1.3 192.168.1.4

               

              Right command:

              vlan 1 ip igmp snooping static-group 232.43.211.234 interface mlag-port-channel 1
              Unfortunately, this does not work because the IPL interface Po11 can not be added to a static group.

               

              mrouter problem:

              When I set the mlag ports as mrouter, I do not get a multicast group, either dynamically or statically.

              Here is the working configuration in a mlag:

              #enable global

              ip igmp snooping


              #enable snooping via vlan
              vlan 1 ip igmp snooping

               

              #enable querier per vlan
              vlan 1 ip igmp snooping querier

              #set the igmp snooping querier ip address in Webui off to free ip 1.1.1.1
              vlan 1 ip igmp snooping querier address 1.1.1.1