1 Reply Latest reply on Feb 25, 2018 3:40 AM by samerka

    Ubuntu Connected mode not working

    boliniak

      Hello I have Connectx-4 VPI (2 port) , I install OFED for Ubuntu and I would like to change port to Connected mode, I done changes in interface file but when I restarted I get :

       

      ib1: Setting Connected Mode failed, not supported by this device

       

      Can somebody can help me with this ?

        • Re: Ubuntu Connected mode not working
          samerka

          Hi Adam,

          In order to set up connected mode, please try first disabling IPoIB enhanced mode to do so please follow the procedure below:

          1) Disable "ipoib_enhanced":

          #vi /etc/modprobe.d/ib_ipoib.conf

           

          Add the following entry:

          options ib_ipoib ipoib_enhanced=0

           

          2) Stop and start openibd service:

          #/etc/init.d/openibd stop

          #/etc/init.d/openibd start

           

          3) Verify parameter is disabled: (The value should be 0)

          #cat /sys/module/ib_ipoib/parameters/ipoib_enhanced

           

          4) Verify the mode:

          #cat /sys/class/net/ib0/mode

           

          Once disabled please go ahead and enable connected mode.

           

          Thanks,

          Samer