3 Replies Latest reply on Dec 11, 2017 6:53 AM by vikiz

    How do I disable FEC for MCX416A-CCAT on windows

    jp_castel

      I have a MCX416A-CCAT I already set the seed to 100Gb and disable auto- negotiation I was wondering if is there a way to disable FEC.

        • Re: How do I disable FEC for MCX416A-CCAT on windows
          vikiz

          Hello,

          Here are the ways to disable FEC on the card:

          1. Connect it to a switch that does not support FEC because our cards set to auto-negotiate by default, meaning if the other side also supports FEC, FEC is enabled. if not, FEC is disabled.
          2. Disable FEC from the switch side, if it’s a Mellanox switch then run:  “ interface ib 1/1 fec-override no-fec” in console terminal mode.
          3. The latest MFT 4.7 package has the mlxlink tool that has the ability to disable FEC as follows:

          a.verify with mlxconfig that KEEP_ETH_LINK_UP_P1 value is 0 (for example: mlxconfig -d /dev/mst/mt4117_pciconf0 q)

          b.disable RS FEC - "mlxlink -d /dev/mst/mt4117_pciconf0 --fec NF"

          c.Toggle link - "mlxlink -d /dev/mst/mt4117_pciconf0 -a TG"

          d.verify FEC is disabled - "mlxlink -d /dev/mst/mt4117_pciconf0 --show_fec |grep -i fec"

          FEC : No FEC

          The MFT (Mellanox firmware tool) can be downloaded from Mellanox fabric website.

           

          Regards,

          Viki

          • Re: How do I disable FEC for MCX416A-CCAT on windows
            vikiz

            Hello,

             

             

            I would like to share that option number 3- using the mlxlink to disable FEC on the server side is relevant only for adapters with speed less than 100G (25G,50G)

            Therefore, the options for disabling FEC on 100G cards are:

            1. Connect it to a switch that does not support FEC because our cards set to auto-negotiate by default, meaning if the other side also supports FEC, FEC is enabled. if not, FEC is disabled.

            2. Disable FEC from the switch side, if it’s a Mellanox switch then run:  “ interface ethernet 1/1 fec-override no-fec” in console terminal mode.

             

             

            Best Regards,

            Viki