1 Reply Latest reply on Jun 28, 2017 12:43 AM by aviap

    Connect-X 2 40Gbps IPoIB Windows-Linux performance issue

    joëlrandrianandrasana

      Hi everyone,

      I need your help !

       

      I'm working with 3 identical boxes embedding Intel Xeon E5-2650 CPUs and connected with Mellanox MT26428 ConnectX-2 40Gbps cards. Two boxes are running Redhat with OpenFabrics driver whereas the third one is running Windows 10 with the last Mellanox WinOFED drivers (note that i only have the admin privileges on the Windows box).

       

      Running iperf gives me an acceptable bandwidth between the 2 Linux boxes (~19 Gbits/sec) but gives me poor results between Linux and Windows (~1.5 Gbits/sec).

       

      I have tried to tune my Windows settings by following this Windows server tunning guide (https://community.mellanox.com/docs/DOC-2312) but i didn't get significant progress.

       

      Do you have any idea concerning this performance issue ?

       

      Due to those IPoIB poor performance between Linux and Windows, i'm considering using RSockets API. Are they supported with Mellanox WinOFED ?

       

      Thank you !

        • Re: Connect-X 2 40Gbps IPoIB Windows-Linux performance issue
          aviap

          There is not much information you're providing on which Linux RH OS you're using, and whether you have install mlnx_ofed driver in Linux server (or you use RH inbox driver) that supports Mellanox CX-2 adapter, but assuming you did, then this make sense that you're getting good performance between the two identical Linux server, however the poor performance you get between Win10 <-> Linux may derive from incompatible WinOF driver installed in Windows.

          I'm not sure what you mean by the "latest Mellanox WinOF driver installed" but the last WinOF driver that supports Mellanox CX-2 adapter (fw 2.9.1200)  is an earlier WinOF v4.80. driver, which is supporting Windows 8.1 Client only,

          In close, I would suggest starting with approaching Mellanox website and line up and install the compatible windows OS, WinOF driver & proper fw that supports CX-2, then finetune the driver & nic parameters and run again the iperf test and see if you get any improvement