2 Replies Latest reply on Dec 5, 2016 6:25 PM by yishuizhao

    infiniband SR-IOV with neutron error

    yishuizhao

      i want to config mellanox infiniband mode sr-iov with openstack liberty by use neutron as link :SR-IOV-Passthrough-For-Networking - OpenStack

      in compute host have two mellanox infiniband card,i confige them SR-IOV with neutron,and install neutron sriov nic agent, but when i complete this configuration,restart this neutron sriov nic agent,it has error as :

      WARNING neutron.plugins.ml2.drivers.mech_sriov.agent.pci_lib [-] Cannot find vfs [0, 1, 2, 3, 4, 5, 6, 7] in device ib0,but i use lspci command which can see the vfs:

      lspci | grep -i mella

      21:00.0 Network controller: Mellanox Technologies MT27500 Family [ConnectX-3]

      21:00.1 Network controller: Mellanox Technologies MT27500/MT27520 Family [ConnectX-3/ConnectX-3 Pro Virtual Function]

      21:00.2 Network controller: Mellanox Technologies MT27500/MT27520 Family [ConnectX-3/ConnectX-3 Pro Virtual Function]

      when i set options mlx4_core num_vfs=8 port_type_array=2,2 probe_vf=0 enable_64b_cqe_eqe=0 log_num_mgm_entry_size=-1,i will see ip link show like this:

      eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000

          link/ether 24:be:05:ab:14:f2 brd ff:ff:ff:ff:ff:ff

          vf 0 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 1 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 2 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 3 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 4 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 5 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 6 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

          vf 7 MAC ff:ff:ff:ff:ff:ff, vlan 65535, spoof checking off, link-state auto

       

      but my switch just support infiniband mode,so this link is down and NO-CARRIER

      when i set options mlx4_core num_vfs=8 port_type_array=1,1 probe_vf=0 enable_64b_cqe_eqe=0 log_num_mgm_entry_size=-1,i will see ip link show like this:

      ib0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP mode DEFAULT qlen 1000

      but no vf can be seen。

       

      who has any idea ?thanks