2 Replies Latest reply on Jun 21, 2016 7:36 AM by jeltef

    Connect-X4 says it doesn't support LINK_TYPE_P1 configuration

    jeltef

      I'm trying to get the MLNX_DPDK 2.2_2.7 driver working for my Connect-X4 card, with MLNX_OFED 3.3-1.0.0.0.

      The manual states that I should change the link type of the ports by doing: (http://www.mellanox.com/related-docs/prod_software/MLNX_DPDK_Quick_Start_Guide_v2.2_2.7.pdf)

      mlxconfig -d /dev/mst/mt4115_pciconf0 set LINK_TYPE_P1=2
      

       

      However, when I do that mlxconfig tells me my device does not support it:

      $ mlxconfig -d /dev/mst/mt4115_pciconf0 set LINK_TYPE_P1=2
      
      Device #1:
      ----------
      
      Device type:    ConnectX4
      PCI device:     /dev/mst/mt4115_pciconf0
      
      Configurations:                              Current         New
      -E- Device doesn't support LINK_TYPE_P1 configuration.
      

       

      Output of some informational commands:

      $ ibv_devinfo
      hca_id: mlx5_1
              transport:                      InfiniBand (0)
              fw_ver:                         12.16.1006
              node_guid:                      e41d:2d03:00c0:88a3
              sys_image_guid:                 e41d:2d03:00c0:88a2
              vendor_id:                      0x02c9
              vendor_part_id:                 4115
              hw_ver:                         0x0
              board_id:                       MT_2150110033
              phys_port_cnt:                  1
              Device ports:
                      port:   1
                              state:                  PORT_DOWN (1)
                              max_mtu:                4096 (5)
                              active_mtu:             1024 (3)
                              sm_lid:                 0
                              port_lid:               0
                              port_lmc:               0x00
                              link_layer:             Ethernet
      
      hca_id: mlx5_0
              transport:                      InfiniBand (0)
              fw_ver:                         12.16.1006
              node_guid:                      e41d:2d03:00c0:88a2
              sys_image_guid:                 e41d:2d03:00c0:88a2
              vendor_id:                      0x02c9
              vendor_part_id:                 4115
              hw_ver:                         0x0
              board_id:                       MT_2150110033
              phys_port_cnt:                  1
              Device ports:
                      port:   1
                              state:                  PORT_ACTIVE (4)
                              max_mtu:                4096 (5)
                              active_mtu:             1024 (3)
                              sm_lid:                 0
                              port_lid:               0
                              port_lmc:               0x00
                              link_layer:             Ethernet
      

       

      $ /etc/init.d/openibd status
      
        HCA driver loaded
      
      Configured Mellanox EN devices:
      eth2
      eth3
      
      Currently active Mellanox devices:
      
      eth3
      
      The following OFED modules are loaded:
      
        rdma_ucm
        rdma_cm
        ib_addr
        ib_ipoib
        mlx4_core
        mlx4_ib
        mlx4_en
        mlx5_core
        mlx5_ib
        ib_uverbs
        ib_umad
        ib_ucm
        ib_sa
        ib_cm
        ib_mad
        ib_core
        ib_netlink