1 Reply Latest reply on Apr 27, 2016 1:38 AM by aviap

    SRP single dual-port HCA multipath config problem

    fiat2000

      I'm running into a problem where the "redundant" connection to a storage system is not coming online for a SRP initiator/target setup where we have a single server direct attached to a storage array.  The server has a dual port MT27600:

       

      lspci | grep -i mell

      02:00.0 Infiniband controller: Mellanox Technologies MT27600 [Connect-IB]

       

      Ca    : 0x5005076061d1cb83 ports 2 "IB Controller"

      Ca    : 0x5849560e566b0301 ports 2 "server002 HCA-1"

       

      ---- Performing Adapter Device Self Test ----

      Number of CAs Detected ................. 1

      PCI Device Check ....................... PASS

      Kernel Arch ............................ x86_64

      Host Driver Version .................... MLNX_OFED_LINUX-3.2-2.0.0.0 (OFED-3.2-2.0.0): 4.2.0-16-generic

      Host Driver RPM Check .................. PASS

      Firmware on CA #0 HCA .................. v10.14.2036

      Firmware Check on CA #0 (HCA) .......... PASS

      Host Driver Initialization ............. PASS

      Number of CA Ports Active .............. 2

      Port State of Port #1 on CA #0 (HCA)..... UP 4X QDR (InfiniBand)

      Port State of Port #2 on CA #0 (HCA)..... UP 4X QDR (InfiniBand)

      Error Counter Check on CA #0 (HCA)...... PASS

      Kernel Syslog Check .................... PASS

      Node GUID on CA #0 (HCA) ............... 58:49:56:0e:56:6b:03:01

      ------------------ DONE ---------------------

       

       

      OpenSM 4.6.1.MLNX20160112