3 Replies Latest reply on Apr 14, 2016 5:21 AM by maxg

    Problems getting ISER working under Ubuntu 15.10

    accs

      I'm trying to get ISER to work under Ubuntu 15.10.  I was able to get RDMA set up and functioning (https://community.mellanox.com/docs/DOC-1465), but I can't get either or TGT to work.

       

      When I try LIO (https://community.mellanox.com/docs/DOC-1468), the ib_sert module won't load.  When I run the "insmod", I get the following:

       

      insmod: ERROR: could not insert module /lib/modules/4.2.0-16-generic/kernel/drivers/infiniband/ulp/isert/ib_isert.ko: Unknown symbol in module

       

      When I try TGT (https://community.mellanox.com/docs/DOC-1459), I can't change the transport from TCP to ISER.

       

      Any help would be appreciated.

       

      EDIT:  I installed the OFED 3.2 drivers and tools.

        • Re: Problems getting ISER working under Ubuntu 15.10
          sophie

          Hi Peter,

           

          This is expected if the following configuration is not in place, please see below:

           

          In the RN, and confirmed by engineering, only following OS supported (without extensions) (ie: 14.04.02,.03,.04):

           

          • RHEL 7.0/7.1/7.2

          • SLES12/12.1

          • Ubuntu14.04, Ubuntu15.04

           

          The right combination is to choose OS from the list with distro kernel and install mlnx_ofed.

          You can also use upstream kernel (the target core is more stable there) instead of mlnx_ofed in order to run isert.

           

          So to clarify:

           

          1) Either Ubuntu 14.04 or 15.04 (no extension) + Mellanox OFED driver.

           

          or

           

          2) Ubuntu 14.04 or 15.04, upstream Kernel with INBOX driver.

           

          Thank you,

          Sophie.

            • Re: Problems getting ISER working under Ubuntu 15.10
              accs

              Sophie,

               

              You're saying that Ubuntu 15.10 isn't a supported platform?  The MLNX_OFED download page disagrees with you.

               

              mlnx_ofed.png

              In any case, it's not worth the effort.  I expect that there's someone out there who actually supports their high performance interconnect on a current OS release ... just not Mellanox.

                • Re: Problems getting ISER working under Ubuntu 15.10
                  maxg

                  Hi Peter,

                  UB15.10 is supported in MLNX_OFED and so does iSER.

                  As Sopie mentioned there is a need to add support to iSER target (ib_isert) for this platform as mentioned in the release notes.

                  TGT is a user space target and I've tried it (on MLNX_OFED-3.3 rc - but it shouldn't matter) and it works for me.

                   

                  please supply more info on the TGT failures (+ all the steps you made) and I'll try to help.

                  thanks,

                  Max.

                  Storage Team.