1 Reply Latest reply on Jan 28, 2016 6:32 PM by rage@mellanox.com

    Number of Virtual Lanes on ConnectX4

    jerome

      Hello,

       

      I'm currently having a question regarding ConnectX4 VPI cards.

       

      I have test environment with connectX4 EDR card, and I would like to test some per VL QoS.

       

      Basically, I have 7 client accessing 1 server, and I would like to dedicate some bandwidth to each client.

      My computer are running Centos7.1 with MLNX_OFED_LINUX-3.1-1.0.3 (OFED-3.1-1.0.3).

       

      Regarding the Product description of ConnectX4, the card should support 8 VL, so on the paper, everything is ok.

       

      My HCA details are :

       

      HCA : ibv_devinfo

      hca_id: mlx5_0

      transport: InfiniBand (0)

      fw_ver: 12.12.1100

      node_guid: e41d:2d03:00f2:9fb4

      sys_image_guid: e41d:2d03:00f2:9fb4

      vendor_id: 0x02c9

      vendor_part_id: 4115

      hw_ver: 0x0

      board_id: MT_2180110032

      phys_port_cnt: 1

      port:      1

      state: PORT_ACTIVE (4)

      max_mtu: 4096 (5)

      active_mtu: 4096 (5)

      sm_lid: 1

      port_lid: 15

      port_lmc: 0x00

      link_layer: InfiniBand

       

       

      On the wire, I see that :

       

      # smpquery PI 15 1 | grep .VL

      VLCap:...........................VL0-3

      OperVLs:.........................VL0-3

       

      So the card is only supporting 4 VL.

       

      What can I do to get 8VL functionning ?

       

      Thanks,

       

      Jerome