2 Replies Latest reply on Nov 9, 2015 1:51 AM by chrisw

    qperf version in RHEL6

    chrisw

      Trying to update a RHEL6 server with mlnx-ofed-all-3.0-1.0.1.noarch installed and having dependency issues.

      When I run yum update all I get -

      Error: Package: mlnx-ofed-all-3.0-1.0.1.noarch (@rh6-mellanox-x86_64)

                 Requires: qperf = 0.4.9-1

                 Removing: qperf-0.4.9-1.x86_64 (@rh6-mellanox-x86_64)

                     qperf = 0.4.9-1

                 Updated By: qperf-0.4.9-1.el6.x86_64 (x86_64-server-6_2015-10-01)

                     qperf = 0.4.9-1.el6

       

      So I can't install the same version!

      Is the mellanox RPM hard coded to look for the exact qperf RPM rather than the version number?

      If so, this needs fixing, if not I'll have to run a yum shell to sort this out.

       

      Kernel version is 2.6.32-504.16.2.el6.x86_64

        • Re: qperf version in RHEL6
          ferbs

          I cant reproduce this using the Mellanox create yum repo script that comes with Mellanox OFED. Can you try the same ?

            • Re: qperf version in RHEL6
              chrisw

              Hi Erez,

              The whole point is that we shouldn't have to use a Mellanox supplied RPM for a package which is already in the official Red Hat channels.

              The advice we got from our 3rd party supplier was to use yum-versionlock, which is rather avoiding the issue IMHO.

              We've had problems with version locking RPMs in the past, as this can also prevent security errata being installed.