3 Replies Latest reply on Oct 7, 2016 11:17 PM by comcomsys

    SX6018 ?? Please Help

    ralphpeters100

      Hi everyone,

       

      I just purchased a SX6018 off of ebay.. I know good/bad decision but either way I need help.. The pull out label is marked P/N: 100-886-230-01 so I presume this unit was manufactured for DELL? Can anyone help me identify what model this is supposed to be? MSX6018F-1SFS, MSX6018F-1BRS, MSX6018T-1SFS, or MSX6018T-1BRS??

       

      Now on to the issues I am having with the unit.. When I first power it on. The switch status LED on the front and back panel remains red for about 1 minute and 10 seconds then turns green. During that time this posts to my terminal screen:

      U-Boot 2009.01 SX_PPC_M460EX SX_3.2.0330-82-EMC ppc (Feb 27 2013 - 12:13:42)

       

       

      CPU:   AMCC PowerPC 460EX Rev. B at 1000 MHz (PLB=166, OPB=83, EBC=83 MHz)

             Security/Kasumi support

             Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)

             Internal PCI arbiter disabled

             32 kB I-Cache 32 kB D-Cache

      Board: Mellanox PPC460EX Board

      FDEF:  No

      I2C:   ready

      DRAM:   2 GB (ECC enabled, 333 MHz, CL3)

      FLASH: 16 MB

      NAND:  1024 MiB

      PCI:   Bus Dev VenId DevId Class Int

      PCIE0: link is not up.

      PCIE1: successfully set as root-complex

              01  00  15b3  c738  0c06  00

      Net:   ppc_4xx_eth0, ppc_4xx_eth1

      Hit any key to stop autoboot:  0

      Waiting for PHY auto negotiation to complete...... TIMEOUT !

      done

      ENET Speed is 10 Mbps - HALF duplex connection (EMAC0)

      Using ppc_4xx_eth0 device

      ping failed; host 172.17.255.252 is not alive

         Loading Kernel Image ... OK

      ABCDEFdrv_table_install:         syslog at 0x00034080 with minor  0 (DRV_SETUP)

      (DRV_INIT)

      drv_table_install:         isrlog at 0x00034080 with minor  1 (DRV_INIT)

      drv_table_install:  userinterface at 0x00004db0 with minor  0 (DRV_SETUP) (DRV_I

      NIT)

      drv_table_install:          stty0 at 0x0006eb7c with minor  0 (DRV_SETUP) (DRV_I

      NIT)

      drv_table_install:           eth0 at 0x0006f50c with minor  0 (DRV_SETUP) (DRV_I

      NIT)

      drv_table_install:           i2c0 at 0x0007a114 with minor  0 (DRV_SETUP) (DRV_I

      NIT)

      drv_table_install:           i2c1 at 0x0007a114 with minor  1 (DRV_INIT)

      drv_table_install:         itcpip at 0x0003c400 with minor  0tcpipInit: Starting

      internal TCP/IP stack.

      (DRV_SETUP) (DRV_INIT)

      kernel_main: Drivers installed, installing INIT process with stack size = 8192.

      Bar [ 0 ] is the first memory bar

      sk_init_main: Starting process based initialization - 8590.

      UDP socket 3 created

      TCP socket 4 created

      sk_init_main: Process based initialization complete - 8590.

      sk_init_main: Installing task table.

      task_table_install:        console at 0x00015ca4 stack 0x00452410/26624 : 4

      task_table_install:          inetd at 0x00035c9c stack 0x00472c10/8192 : 5

      task_table_install:       poll_cqs at 0x000aa98c stack 0x00458c10/8192 : 6

      task_table_install:     poll_ports at 0x000aaac4 stack 0x0045ac10/8192 : 7

      task_table_install:        env_mon at 0x000832f4 stack 0x0045ec10/8192 : 8

      task_table_install:    env_bin_api at 0x00014420 stack 0x00460c10/8192 : 9

      task_table_install: incoming_fw_files at 0x00013e84 stack 0x00462c10/8192 : 10

      task_table_install: incoming_fw_files at 0x00013e84 stack 0x00464c10/8192 : 11

      sk_init_main: Task table installed.  Starting tasks and exiting.

      ----------------------------- Board Info -----------------------------

      * Chasis Type         : STINGRAY

      * Number of Ports     : 18

      * U-Boot Revision     : 3.2.330

      * Firmware Revision   : 9.9.1030

      * INI file Revision   : 0x21010009

      * SwitchOS Revision   : 1.297

      * SwitchOS Build Date : 2013-08-02

      * SwitchOS Build Time : 16:34:58

      * SwitchOS Build Path : /emc/tdowning/ppc460_release/aug_02_2013

      ----------------------------------------------------------------------

      21:12:41 09/24/2014

      Switch-X(4)>

       

      I'm confused as to how do I login to the system to configure the unit? The user manual states "Login (from a serial terminal program) as admin and use admin as password. This starts the Mellanox configuration wizard."

      When I type in admin at the prompt the response is:

       

      Switch-X(4)> admin

      admin: Command not found.

      Switch-X(4)>

       

      So am I doing something wrong? Or is the SX6018 Defective? The person I purchased the unit from gave me a 30 day warranty which I have about 18 days to return the unit if it is defective.. I should also note the LED indicators on the back panel for each of the two power supplies are off and so is the LED indicator on the fan unit. The LED indicators on the front panel for the fan, PS1, and PS2 are off as well.. So that has me really confused as the fans are running and the power supplies has the unit powered up..

       

      Please help and Thank You in advance,

       

      RalphPeters100

       

        • Re: SX6018 ?? Please Help
          eddie.notz

          Hi Robert/Ralph,

           

          This an EMC switch - it's their OS running on a Mellanox HW.

          I think you should be more cautious when buying from EBAY.

            • Re: SX6018 ?? Please Help
              bmac2099

              hi

              do you have access to mellanox to get the MLNX-OS?

               

              if so, i can show you how to update the firmware of your switch back to mellanox, by doing a custom firmware build.  i  have done it sucessfully on 4 x SX6012 and 6005 Switches.  But need the MLNX-OS software to install on the switch, and mellanox kindly wont give me access to download MLNX-OS!

               

              Angry!

                • Re: SX6018 ?? Please Help
                  comcomsys

                  hi bruce

                  I've the same problems with a SX6018 Switch out of ebay, because it is an EMC. I do have an actual Image of MLNX-OS for that switch, but I dont know any way to bring it up. So if you have an idea, i would be able to share my image.

                  full of hope

                  herbie