2 Replies Latest reply on Jan 28, 2015 4:59 PM by ophirmaor

    LAG, Lacp configuration on Mellanox switches

    einave

      Following the user manual of mlnx_os 3.4.0012 these are the instructions for enabling lacp:

       

      Step 1. Log in as admin.

      Step 2. Enter config mode. Run:

      Step 3. Create a port-channel entity. Run:

      Step 4. Change back to config mode. Run:

      switch > enable

      switch # configure terminal

      switch (config) # interface port-channel 1

      switch (config interface port-channel 1) #

      switch (config interface port-channel 1) # exit

      switch (config) #

      switch (config interface ethernet 1/4) # channel-group 1 mode on

      switch (config interface ethernet 1/4) #

      If the physical port is operationally up, this port becomes an active member of the

      aggregation. Consequently, it becomes able to convey traffic.

      switch > enable

      switch # configure terminal

      switch (config) # interface port-channel 1

      switch (config interface port-channel 1) #

      switch (config interface port-channel 1) # exit

      switch (config) #

      Rev 3.30

      Mellanox Technologies 480

      Mellanox Technologies Confidential

      Step 5. Enable LACP in the switch. Run:

      Step 6. Add a physical port to the port-channel. Run:

      switch (config) # lacp

      switch (config) #

      switch (config interface ethernet 1/4) # channel-group 1 mode active/passive

      switch (config interface ethernet 1/4) #

       

      Running it in lab I get the following:

      (port channel 1 is already configured)

       

      sx6036-gso [standalone: master] (config interface ethernet 1/23) # channel-group 1 mode active

      % Cannot add Interface Eth1/23 with channel-group mode (active) to channel-group 1 mode (on) - Incompatible mode

      sx6036-gso [standalone: master] (config interface ethernet 1/23) # channel-group 1 mode passive

      % Cannot add Interface Eth1/23 with channel-group mode (passive) to channel-group 1 mode (on) - Incompatible mode

       

      Any idea why?

       

      Thanks,

      Einav.