2 Replies Latest reply on Jul 1, 2014 3:10 AM by ferbs

    The MaxReadRequest size is set too low (512 bytes)

      At the end of the OFED installation, I receive this advice:

      Device (41:00.0):

              41:00.0 Network controller: Mellanox Technologies MT27500 Family [ConnectX-3]

              WARNING - device 41:00.0 The MaxReadRequest size is set too low (512 bytes) and will affect performance.

              Please consult your server's vendor and if possible change BIOS settings or use setpci to configure MaxReadReq to 4096 bytes.

              # /usr/bin/setpci -s 41:00.0 68.W

              2xxx

              Change to 4096 bytes:

              # /usr/bin/setpci -s 41:00.0 68.W=5xxx

       

      The current value is:

      $ sudo /usr/bin/setpci -s 41:00.0 68.W

      2000

       

      I don't see a relevant BIOS setting ( Poweredge C6145 ), so considering the setpci route.

      So I assume the advice would be to do the following (I haven't yet):

      $ sudo /usr/bin/setpci -s 41:00.0 68.W=5000

      Reading elsewhere ( setup MaxReadReq to 4096 bytes definitely ) it seems this isn't a permanent solution, and something similar can done by setting ib_mthca tune_pci=1 in /etc/modprobe.conf. What's the preferred solution to fix the MaxReadRequest issue?