5 Replies Latest reply on Sep 23, 2014 12:16 AM by eddie.notz

    UFM 4.0 GUI hangs in "Initializing ..." state

      Hello,

       

      I just installed UFM 4.0 on a RHEL5; the UFM is configured to run in monitor mode, and `ufmd` starts successfully:

       

       

      ================================================================================
      UFM daemon is starting UFM server on master2 at mer apr 2 10:56:05 CEST 2014
      ================================================================================
      2014-04-02 10:56:06.476 ufm   INIT    UFM Enterprise Server started
      2014-04-02 10:56:06.478 ufm   INIT    DHCP Daemon id disabled
      2014-04-02 10:56:06.479 ufm   INIT    SNMPTrapNotifier init
      2014-04-02 10:56:06.479 ufm   INIT    UFM server is running in Monitoring mode
      2014-04-02 10:56:06.785 ufm   INIT    Grid Load from DB before discovery started
      2014-04-02 10:56:06.786 ufm   INIT    Grid start load from DB before discovery
      2014-04-02 10:56:06.792 ufm   INIT    Grid complete load from DB before discovery
      2014-04-02 10:56:06.792 ufm   INIT    Grid Load from DB before discovery finished
      2014-04-02 10:56:09.612 ufm   INIT    WS server started
      2014-04-02 10:56:09.700 ufm   INIT    Site default starting discovery
      2014-04-02 10:56:09.700 ufm   INIT    TrapDispatcher init, port 162
      2014-04-02 10:56:09.701 ufm   INIT    OpenSM plug-in Events Dispatcher started on port 8082
      2014-04-02 10:56:09.738 ufm   INIT    Device agent listener started
      2014-04-02 10:56:09.738 ufm   INIT    Statistics server started
      2014-04-02 10:56:09.739 ufm   INIT    Initialization done, UFM server is ready
      2014-04-02 10:56:09.739 ufm   INIT    2014-04-02 10:56:09.739350:TrapDispatcher started

       

       

      I can connect to the http port and start the Java GUI: the dashboard opens, but then I see two splash windows saying "Unified Fabric Manager Initializing ..." and they never go away.  The dashboard is unresponsive and cannot be clicked.

       

      What can I do to debug this problem?

       

      Could this be related to the OpenSM <-> UFM interactions?  The OpenSM that comes with UFM is running fine, but it is the *backup* OpenSM on my fabric, not the active one; I do not see any entries being added to /opt/ufm/log/events.log so it is probably not getting the kind of information that UFM needs?

       

      Thanks,

      Riccardo

        • Re: UFM 4.0 GUI hangs in "Initializing ..." state
          yairi

          Hi Riccardo,

          How big is this cluster you are monitoring?

          I am not sure what the problem is but i can tell that the guys in the shop were adding many features and fixes related to scalability and the ability of the GUI with handling large fabrics. Please consider uplifting the UFM to the latest (currently 4.6.1) which will require you to also update your OS to > RHEL6.3.

           

          it could be that your Java client is also causing this. clean your cash; make sure you work with Oracle Java webstart *latest revision* (other Java provider may not support all functions that UFM is asking for)

            • Re: UFM 4.0 GUI hangs in "Initializing ..." state

              Hi Yairi,

              thanks for your reply!


              > How big is this cluster you are monitoring?

              It's about 700 nodes, ~4700 IB ports total (including hosts and

              switches).


              > I am not sure what the problem is but i can tell that the guys in the shop
              > were adding many features and fixes related to scalability and the ability
              > of the GUI with handling large fabrics. Please consider uplifting the UFM to
              > the latest (currently 4.6.1) which will require you to also update your OS
              > to > RHEL6.3.

              Unfortunately upgrading to RHEL6.3 just for testing UFM is not an

              option.  Does the latest UFM also run on Ubuntu?


              > it could be that your Java client is also causing this. clean your cash;
              > make sure you work with Oracle Java webstart *latest revision* (other Java
              > provider may not support all functions that UFM is asking for)

              Shouldn't I get an error of some kind if the Java code is using

              features that the runtime does not support?

               

              Thanks,

               

              Riccardo

            • Re: UFM 4.0 GUI hangs in "Initializing ..." state
              yairi

              Hi Riccardo,

              Upgrading the OS and UFM is something I recommend you doing anyhow (not just for testing. Should you choose to stay with RHEL5 this might be a problem with future upgrades going forward. Besides, the newer versions of UFM gets only better and better...

               

              As for your Java, not sure whether i can specify any specific error. All kind of Function not supported variations are included. Get your Java from https://www.java.com/en/download/ - This is the ONLY java i know working for this product.

              • Re: UFM 4.0 GUI hangs in "Initializing ..." state
                ferbs

                Hi Riccardo,

                 

                Since the UFM is running on monitoring mode it may mean that the host the UFM is installed on is getting any events from the Actual SM.

                 

                Might be a good idea to share the output of "ibstat" "sminfo" and "ifconfig" from that host.