1 Reply Latest reply on Apr 7, 2015 5:27 PM by mbanic

    Installation of 4.60 fails in german version of 2008R2x64

      Hi all

       

      I tried to install in a VSphere 5.5 based the package MLNX_VPI_WinOF-4_60_All_win2008R2_x64 in a german version of Windows Server 2008 R2 x64.

       

      The IB card used is a MHQH29C-XTR with firmware 2.9.100.

       

      The IB card is used via PCI Passthrough.

       

      During the installation the inf files written in C:\Windows\System32\DriverStore\FileRepository are unreadable.

      If loaded in notepad values of null are shown.

       

      In the log file I find this message

      DIFXAPP: INFO:   Could not open file C:\Windows\System32\DriverStore\FileRepository\mlx4_bus.inf_amd64_neutral_bd8d9e79897dc5d7\mlx4_bus.inf. (Error code 0xE0000100: Der INF-Stil unterscheidet sich von der Anforderung.)

      translates to: "The style of the inf-file differs from the requested style".

       

      If the damaged inf files are replaced by the correct ones from the folder of Mellanox in %programfiles% and the installation is repeated a sudden reboot occurs.

       

      The last lines written in the logfile are:

      ....

      DIFXAPP: INFO:   Installing devices with Id "PCI\VEN_15B3&DEV_673C&SUBSYS_003615B3&REV_B0" using INF "C:\Windows\System32\DriverStore\FileRepository\mlx4_bus.inf_amd64_neutral_bd8d9e79897dc5d7\mlx4_bus.inf".

      MSI (s) (80!F8) [22:04:57:938]: Closing MSIHANDLE (230) of type 790531 for thread 760

      MSI (s) (80!F8) [22:04:57:938]: Creating MSIHANDLE (231) of type 790531 for thread 760

      DIFXAPP: INFO:   Will force install because driver is not better and force flag is set.

      MSI (s) (80!F8) [22:04:57:938]: Closing MSIHANDLE (231) of type 790531 for thread 760

      MSI (s) (80!F8) [22:04:57:938]: Creating MSIHANDLE (232) of type 790531 for thread 760

      DIFXAPP: INFO:   ENTER UpdateDriverForPlugAndPlayDevices...

       

       

      The sudden reboot occurs too when I open the device manager and try to install the mlx bus driver from the HW subfolder.

       

      Kind regards

       

      Andreas