1 Reply Latest reply on Jul 10, 2013 11:50 PM by ysdimov

    Windows Server 2012 R2 Problems


      Server 2012 R2 preview version. Our setup has the Mellanox ConnectX3 EN Dual Port Ethernet adapters with firmware version of 2.11.500

       

      Im creating LBFO team (evendynamic, hyper-v port or hash with static teaming) on a new Windows Server 2012
      R2 OS installation without any roles or custom configurations. After restart of OS the teamed adapter disappears from Network Adapter Configuration. Inside Team Management its still persist but in faulty state and Faulted Not Found
      reason for each adapter of the team. When I checked Device Manager Microsoft Network Adapter Multiplexor Driver is installed but greyed out like the hardware is unplugged for example.

       

      As workaround I can uncheck an adapter from the team, apply the configuration, recheck it apply configuration which cause to reconnect/install/plug the teamed adapter and it appears immediately and reconnects the port in healthy state. I can do this for each
      port but once I restart the node again in goes in faulty state and the teamed adapter disappears.

       

      Update:

      http://www.mellanox.com/page/products_dyn?id=129&product_family=129&menu_section=34

       

      I have downloaded these drivers and somehow I fixed the problem on one of my cluster nodes. The problem is that I cannot fix it in the same way on my second node Ill keep you updated

       

        • Re: Windows Server 2012 R2 Problems

          Unfortunately somehow I was able to fix the problem only on one of my nodes but I was not able to reproduce it on the second ?!

              

          From Microsoft confirmed that the problem is because of the driver. Im with the latest firmware and driver.

           

          Driver Version : 4.40.14223.0

          Firmware Version : 2.11.500

          Port Number : 1

          Bus Type : PCI-E 5.0 Gbps x8

          Link Speed : 10.0 Gbps/Full Duplex

          Part Number : MCX312A-XCBT

          Device Id : 4099

          Revision Id : 0

           

          Network Status : Disabled

          Adapter Friendly Name :      -    

          IPv4 Address :      -    

          Adapter User Name :      -   

              

          Here’s the analysis from Microsoft team:

             ““TeamCreationFromSCVMM2012R2” and “AfterReboot” have only two types of errors (for each team member):

           

           

          • Binding
            to member adapter
            NDISIMPLATFORM\Parameters\Adapters\{FDBF280B-2542-4537-B7F1-4494DFFC8D10}
            failed. Status = -1073741661. Potential reason could be inadequate capabilities.
          • Creating
            internal binding between TeamNic {F4531B76-5884-4A5E-BF04-37A18864A0D3} and
            Member
            NDISIMPLATFORM\Parameters\Adapters\{93A7542D-1D95-4C96-9CF7-F050306DEC1B}
            failed. Status = -1073741661

           

          “RemoveAddNICFromTeam” has no errors in the log.

           

          Thus,we can confirm that IM Platform is rejecting binding to these team members. The
          status code of -1073741661 corresponds to STATUS_DEVICE_NOT_READY. Most likely,
          the miniport driver has failed some OID with this status code (maybe packet
          filters, offload parameters or something similar), but we don’t know for sure.

           

          In short, we think the problem is
          in the miniport driver, which is provided by Mellanox in this case. So
          contacting Mellanox is the right next step.”