7 Replies Latest reply on Jun 22, 2013 7:33 PM by yairi

    UFM 4.0 server connection error - server not responding


      I have installed UFM 4.0 to evaluate it for use on our processing cluster.  We are running a standalone installation under Red Hat 6.0.  We are able to start ufmd successfully, but when I execute ufmcli or ufmui under Firefox, after logging in, the message "UFM Server is not responding" is received.  The firewall is disabled, and selinux is disabled.  Does anyone have an idea why UFM server isn't responding or suggest something to check?

        • Re: UFM 4.0 server connection error - server not responding
          yairi

          i am guessing that you:

          A) have a license and

          B) Started the ufmd service (and there were no errors).

           

          what do you see in /var/log/messages around this event?

          also, under /opt/ufm/files/log/ check ufm.log and console.log

           

          let me know what do you see there.

            • Re: UFM 4.0 server connection error - server not responding

              Hello.  Yes, I have a license and I started ufmd with no errors.

               

              In /var/log/messages, I see the following:

               

              ufm:  ufmd monitor

              ufm:  Running UFM in monitoring mode

              ufm:  Starting ibsim with options: -P 412 -S 9 -N 43 -L 30000

              OpenSM[20441]:  Loading Cached option:guid = 0x0002c903000eb15b#012

              OpenSM[20441]:  Loading Cached option:max_op_vls = 4#012

               

              .... a bunch more of the OpenSM lines .....  the last one was:

               

              OpenSM[20441]:  Entering MASTER state#012

              ufmd:  starting ibpm on hca:m1x4_0 port:1

              ufm_ibsim:  start ufm_ibsim

              ufm_ibsim:  ufm read topology

                • Re: UFM 4.0 server connection error - server not responding
                  yairi

                  i see.. so you are in monitoring mode. were you able to see anything in ufm.log or the console.log?

                    • Re: UFM 4.0 server connection error - server not responding

                      Yes, part of my response was cut off, apparently because I had some

                      underline characters.  Here is the rest of the log contents.

                       

                      Under ufm.log in /opt/ufm/files/log/, there is the following:

                       

                      UFM daemon is starting UFM server on .....

                      ufm  INIT UFM Enterprise Server started

                      ufm  ERROR  Cannot get data for interface ib0

                      ufm  CRITICAL  Attempt 0 Querying interface for management network ib0

                      failed,

                      please check that the interface is running and has IP address

                       

                      ....and more of the same.

                       

                      Under console.log in /opt/ufm/files/log/, there are the same statements as

                      in ufm.log.

                       

                      It looks like we have a problem with the setup of our ib0 port.  How do we

                      set it up?  Our HCA is a Mellanox adapter on an HS22 blade, installed in an

                      IBM BladeCenter H.  We added ifcfg-Auto_ib0

                      under /etc/sysconfig/network-scripts, but no effect on UFM.

                                                                                            

                      *

                      *

                      *                                                                       

                      UFM 4.0 server connection error - server not responding            

                      reply from yairi in Unified Fabric Manager (UFM) - View the full    

                      discussion                                                                              

                      i see.. so you are in monitoring mode. were you able to see anything in

                      ufm.log or the console.log?                                                                              

                      Reply to this message by replying to this email, or go to the message on

                      Mellanox Interconnect Community                                    

                      Start a new discussion in Unified Fabric Manager (UFM) by email or at

                      Mellanox Interconnect Community                                    

                      Following UFM 4.0 server connection error - server not responding in these

                      streams: Inbox

                      • Re: UFM 4.0 server connection error - server not responding

                        We have succeeded in running UFM.  We used the "ip" command to do a "link

                        set" and "address add", and that fixed the UFM Server response problem.

                    • Re: UFM 4.0 server connection error - server not responding

                      Hello.  Yes, I have a license and I started ufmd with no errors.

                       

                      In /var/log/messages, I see the following:

                       

                      ufm:  ufmd monitor

                      ufm:  Running UFM in monitoring mode

                      ufm:  Starting ibsim with options: -P 412 -S 9 -N 43 -L 30000

                      OpenSM[20441]:  Loading Cached option:guid = 0x0002c903000eb15b#012

                      OpenSM[20441]:  Loading Cached option:max_op_vls = 4#012

                       

                      .... a bunch more of the OpenSM lines .....  the last one was:

                       

                      OpenSM[20441]:  Entering MASTER state#012

                      ufmd:  starting ibpm on hca:m1x4_0 port:1

                      ufm_ibsim:  start ufm_ibsim

                      ufm_ibsim:  ufm read topology

                       

                      Under ufm.log in /opt/ufm/files/log/, there is the following:

                       

                      UFM daemon is starting UFM server on .....

                      ufm  INIT UFM Enterprise Server started

                      ufm  ERROR  Cannot get data for interface ib0

                      ufm  CRITICAL  Attempt 0 Querying interface for management network ib0

                      failed,

                      please check that the interface is running and has IP address

                       

                      ....and more of the same.

                       

                      Under console.log in /opt/ufm/files/log/, there are the same statements as

                      in ufm.log.

                       

                      It looks like we have a problem with the setup of our ib0 port.  How do we

                      set it up?  Our HCA is a Mellanox adapter on an HS22 blade, installed in an

                      IBM BladeCenter H.

                       

                       

                      *****======******

                                                                                                 

                      UFM 4.0 server connection error - server not responding           

                      reply from yairi in Unified Fabric Manager (UFM) - View the full   

                      discussion                                                                             

                      i am guessing that you:                                           

                      A) have a license and                                             

                      B) Started the ufmd service (and there were no errors).                                                                             

                      what do you see in /var/log/messages around this event?           

                      also, under /opt/ufm/files/log/ check ufm.log and console.log                                                                             

                      let me know what do you see there.                                                                             

                      Reply to this message by replying to this email, or go to the message on

                      Mellanox Interconnect Community                                   

                      Start a new discussion in Unified Fabric Manager (UFM) by email or at

                      Mellanox Interconnect Community                                   

                      Following UFM 4.0 server connection error - server not responding in these

                      streams: Inbox