HowTo Enable PFC on Dell S6000/S4810

Version 7

    This post discusses the PFC configuration flow for Dell's S6000 or Dell S4810 switch.

     

    References

     

    Configuration

    1. Enable dot1p and dcb on the switch:

    # service-class dynamic dot1p

    # dcb enable

     

    2. Create dcb map profile:

    # dcb-map my-dcb-map-profile

    Under this profile, configure two (or more) priority groups.

     

    A priority group is a group of several priorities. For example:

    • priority-group 0 is a group of all priorities besides 3 (0,1,2,4,5,6,7)
    • priority-group 1 is a group of single priority: 3

     

    (Optional) It is possible to set specific bandwidth for each priority group, for example:

    • 90% for priority-group 0
    • 10% for priority-group 1

     

    This configuration should be aligned all over the network.

    If you change the bandwidth per priority group on the switch, you need to make sure it is also done on the adapter cards:

    # priority-group 0 bandwidth 90 pfc on

    # priority-group 1 bandwidth 10 pfc off

    # priority-pgid 1 1 1 0 1 1 1 1

     

     

    3. Set the desired interface with the configured dcb profile:

        For example, the port 0/32:

    # interface TenGigabitEthernet 0/32

    # no ip address

    # switchport

    # spanning-tree rstp edge-port

    # dcb-map my-dcb-map-profile    -- This is the mapping of a profile.

    # no shutdown

     

    4. Make sure that the desired VLAN is enabled on the port in tagged mode:

    # interface Vlan 2
    # no ip address
    # tagged TenGigabitEthernet 0/32 -– this is a tagged interface for VLAN 2.
    # no shutdown

     

     

    Full Running config example

    S6000 # show running-config

    Current Configuration ...

    ! Version 9.6(0.0)

    ! Last configuration change at Tue Jan 13 08:49:08 2015 by admin

    ! Startup-config last updated at Tue Jan  6 03:06:35 2015 by admin

    !

    boot system stack-unit 0 primary system: A:

    boot system stack-unit 0 secondary system: B:

    boot system stack-unit 0 default system: A:

    !

    redundancy auto-synchronize full

    !

    hardware watchdog stack-unit 0

    hardware watchdog stack-unit 1

    hardware watchdog stack-unit 2

    hardware watchdog stack-unit 3

    hardware watchdog stack-unit 4

    hardware watchdog stack-unit 5

    !

    hostname S6000

    !

    username admin password 7 89afe0892189bd96 privilege 15

    !

    stack-unit 0 provision S6000

    !

    stack-unit 0 port 0 portmode quad

    !

    stack-unit 0 port 32 portmode quad

    !

    interface TenGigabitEthernet 0/0

    description SMB3

    no ip address

    mtu 12000

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface TenGigabitEthernet 0/1

    description SMB3

    no ip address

    mtu 12000

    switchport

    spanning-tree rstp edge-port

    dcb-map my-dcb-map-profile

    no shutdown

    !

    interface TenGigabitEthernet 0/2

    description SMB3

    no ip address

    mtu 12000

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface TenGigabitEthernet 0/3

    description SMB3

    no ip address

    mtu 12000

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface fortyGigE 0/4

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/8

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/12

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/16

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/20

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/24

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/28

    no ip address

    switchport

    no shutdown

    !

    interface TenGigabitEthernet 0/32

    no ip address

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface TenGigabitEthernet 0/33

    no ip address

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface TenGigabitEthernet 0/34

    no ip address

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface TenGigabitEthernet 0/35

    no ip address

    switchport

    spanning-tree rstp edge-port

    dcb-map dcb-smb-default

    no shutdown

    !

    interface fortyGigE 0/36

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/40

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/44

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/48

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/52

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/56

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/60

    no ip address

    switchport

    no shutdown

    !

    interface fortyGigE 0/64

    no ip address

    no shutdown

    !

    interface fortyGigE 0/68

    no ip address

    no shutdown

    !

    interface fortyGigE 0/72

    no ip address

    no shutdown

    !

    interface fortyGigE 0/76

    no ip address

    no shutdown

    !

    interface fortyGigE 0/80

    no ip address

    no shutdown

    !

    interface fortyGigE 0/84

    no ip address

    no shutdown

    !

    interface fortyGigE 0/88

    no ip address

    no shutdown

    !

    interface fortyGigE 0/92

    no ip address

    no shutdown

    !

    interface fortyGigE 0/96

    no ip address

    no shutdown

    !

    interface fortyGigE 0/100

    no ip address

    no shutdown

    !

    interface fortyGigE 0/104

    no ip address

    no shutdown

    !

    interface fortyGigE 0/108

    no ip address

    no shutdown

    !

    interface fortyGigE 0/112

    no ip address

    no shutdown

    !

    interface fortyGigE 0/116

    no ip address

    no shutdown

    !

    interface fortyGigE 0/120

    no ip address

    no shutdown

    !

    interface fortyGigE 0/124

    no ip address

    no shutdown

    !

    interface ManagementEthernet 0/0

    ip address 172.30.207.241/22

    no shutdown

    !

    interface ManagementEthernet 1/0

    no shutdown

    !

    interface ManagementEthernet 2/0

    no shutdown

    !

    interface ManagementEthernet 3/0

    no shutdown

    !

    interface ManagementEthernet 4/0

    no shutdown

    !

    interface ManagementEthernet 5/0

    no shutdown

    !

    interface Vlan 1

    !

    interface Vlan 2

    no ip address

    tagged TenGigabitEthernet 0/0-3,32-35

    untagged fortyGigE 0/4,8,12,16,20,24,28

    no shutdown

    !

    interface Vlan 3

    no ip address

    untagged fortyGigE 0/36,40,44,48,52,56,60

    no shutdown

    !

    management route 0.0.0.0/0 172.30.204.1

    !

    service-class dynamic dot1p

    !

    dcb enable

    !

    dcb-map my-dcb-map-profile

    priority-group 0 bandwidth 90 pfc on

    priority-group 1 bandwidth 10 pfc off

    priority-pgid 1 1 1 0 1 1 1 1

    !

    no protocol lldp

    !

    line console 0

    line vty 0

    line vty 1

    line vty 2

    line vty 3

    line vty 4

    line vty 5

    line vty 6

    line vty 7

    line vty 8

    line vty 9

    !

    reload-type normal-reload

    !

    end